Use the free draw.io add-in for Microsoft Office products (Word, Excel and Powerpoint) to embed your diagrams into your documents. When you make changes to your diagram, you need to update them inside your document to see the changes.


Install the draw.io add-in

  1. Go to https://appsource.microsoft.com/en-us/product/office/wa200000113, make sure you are signed in, and click on Get it now.
  2. Click Continue. You’ll be redirected to the Office 365 site if you are logged into a personal account.
  3. Click on the product button in which you want to install the add-in, for example, Open in Word.
  4. Use the example document to learn how to use the draw.io add-in in your Microsoft product.
  5. Start using the add-in via the Insert tab in the toolbar in any new or existing document.

Note: Your diagram data is only ever stored in your browser and either on your device, or in your cloud platform (OneDrive or Google Drive).

Embed a diagram in a Word document

  1. Go to the Insert tab on the toolbar in Word.
  2. Click on the draw.io icon, then pick where you have saved your diagram file: OneDrive, Google Drive or on your local device.
  3. Navigate to and select your file. You may need to log into your account, and grant permission for the add-in to access your files (if you selected OneDrive or Google Drive).
  4. If your diagram has multiple pages, select which page you want to display, then insert your diagram.

Resize and rotate your diagram

Your diagram is embedded as an image, and can be edited like any other embedded picture in your document.

  1. First, select the diagram in your document.
  2. Drag the grab handles on the side or corners to resize it.
  3. Drag the rotate handle at the top of your diagram to rotate it.

Recolour your diagram

  1. Select the diagram, then select the Picture Format tab in the toolbar.
  2. Click on the Color tool in the toolbar, then select a new colour. Note that this does not change the colours in the diagram file.

Update embedded diagrams to see changes

Your diagrams are displayed as images inside your Word document, Excel spreadsheet or Powerpoint presentation. When the diagram file that is stored in your Google Drive or One Drive has been edited in diagrams.net, you’ll need to regenerate the images to see those changes reflected in your document.

  1. Select the Insert tab in the toolbar.
  2. Select the diagram you want to update, and click Update Selected. To update all of the diagrams in your document, click Update All.

Edit the embedded diagram

  1. Select the diagram you want to edit.
  2. Select the Insert tab in the toolbar, then click Edit Selected. Your diagram will open in the editor at diagrams.net.