FAQ

How to customize shapes?
Let us start by adding a rectangle from the General library menu.  Click the rectangle shape (the top left shape), drag it somewhere on your diagram, and th...
Mon, 16 Oct, 2017 at 10:13 AM
How to use Insert Functions?
The toolbar is located immediately below the menu bar, and contains a variety of useful functions.  These functions can all be accessed in other ways, but a...
Mon, 16 Oct, 2017 at 10:19 AM
How to use Arrange Functions?
Let us start by looking at the ways in which you can quickly build up collections of diagram elements.  A number of commonly used arrangements are availab...
Mon, 16 Oct, 2017 at 10:29 AM
How to alter shapes?
Rotating Shapes When you create a new shape, it always starts off oriented in some way relative to the page. For example, a cylinder will always appear ...
Mon, 16 Oct, 2017 at 10:32 AM
How to use Connectors?
There are two ways to attach a connector to a shape, which we will look at now.  We can create either an anchored connection, or a floating connection. ...
Mon, 20 Jan, 2020 at 11:35 PM
How to work with Metadata?
Editing File Metadata A draw.io diagram can be represented using XML metadata, and it is possible to view and edit the metadata file associated with a d...
Mon, 16 Oct, 2017 at 11:08 AM
How to use Layers?
It is possible to create a diagram that contains different layers of elements.  Each layer and its elements will display together (unless you specify otherw...
Wed, 22 Jul, 2020 at 11:42 PM
How to use the Help Menu
Selecting the Help menu from the menu bar presents us with a number of options.     Help Search Function The first option is the search ...
Mon, 16 Oct, 2017 at 11:18 AM
How to use Online Support
Shown below is the draw.io Online Support page.  This page can be accessed via the following link: draw.io Online Support It can also be accessed by Selec...
Mon, 16 Oct, 2017 at 11:20 AM
Where has the csv import moved to
The .csv import has moved from File->Import From to Arrange->Insert
Wed, 13 Jun, 2018 at 11:33 AM